فناوری اطلاعات

آسیب پذیری در پلاگین های وردپرس

منبع: ایرنا
محققان شرکت بین المللی Scrutinizer (فعال در حوزه تولید نرم افزار و امنیت سایبر) اخیرا یک آسیب پذیری در پلاگین های وردپرس کشف کرده اند که به علت استفاده ناامن از توابعadd_query_arg و remove_query_arg وردپرس ایجاد شده است.
ضربه ناشی از این مشکل بستگی به نقش کاربر بر روی وب سایت دارد.به عنوان مثال، اگر قربانی دارای حق دسترسی مدیریتی باشد مهاجم می تواند برای انجام عملیات مدیریتی از آن سوء استفاده کند.
 
اگر قربانی نقش عادی داشته باشد مهاجم می تواند کوکی های تایید هویت آن ها را به سرقت برده و حساب کاربری را ارتباط ربایی نماید.
 
محققان Scrutinizer بر این باور هستند که در اصل این مشکل در پلاگین های WordPress SEO و Google Analytics که توسط Yoast ایجاد شده وجود دارد.
 
اسکن بیش از 400 پلاگین معروف وردپرس نشان می دهد که بیش از 12 پلاگین دارای آسیب پذیری مشابه می باشند. تم ها نیز تحت تاثیر این مشکل قرار دارند.
 
پلاگین های که دارای آسیب پذیری می باشند به زودی اصلاح می شوند در نتیجه به کاربران وردپرس توصیه می شود تا داشبوردهای مدیریتی را برای به روز رسانی پلاگین ها بررسی کنند. برخی پلاگین ها به صورت خودکار به روز رسانی می شوند.
 
از آن جا که احتمالا پلاگین ها و تم های آسیب پذیر زیادی وجود دارد که هنوز شناسایی نشده اند، توصیه می شود تا کدهای خود را به منظور بررسی استفاده ناامن از توابعadd_query_arg و remove_query_arg بازبینی کنند.

​​